Results 1 to 2 of 2

Thread: Canon 7D, 70-200mmL f4 IS, Kenko DGX 1.4x TC

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Senior Member Jayson's Avatar
    Join Date
    Dec 2008
    Location
    Nebraska, USA
    Posts
    1,678

    Canon 7D, 70-200mmL f4 IS, Kenko DGX 1.4x TC



    I have this combo. I also have the original Kenko Pro 300 DG. The new one that they came out with (DGX) is suppose to have more circuits that allows the camera to communicate better with the lens it is using to transfer the EXIF data a little better than the old. I had ordered this new one a little while back as I was going to stack the two 1.4 TC together to get a little longer reach until I could afford something longer in the Canon lens lineup.


    Here's my problem and didn't know if anyone had an answer for this. The new DGX does not work with this lens. It works with every other lens that I own including those shorter than 100mm just like the old. It reports the correct information to the camera so all is good with that. I for some reason cannot get this converter to work with the 70-200mmL f4 IS. When it is connected, the readout shows the shutter speed, but no f value. The camera will not AF with this TC either. Other than taping pins, anyone have a clue how to fix this phenomenon? It works when I stack the two, but doesn't work when it is all by itself with the lens.


    Appreciate any feed back. Thanks,


    Jayson

  2. #2
    Senior Member
    Join Date
    Dec 2008
    Posts
    228

    Re: Canon 7D, 70-200mmL f4 IS, Kenko DGX 1.4x TC



    You either have a defective lens, or a defective TC. The lens is suspect since all your other lenses work with it. If you had a Canon TC, you could send them both in and whichever was bad could be repaired. My 70-200mm f/4 IS certainly reports fine with my Canon 1.4 and 2X TC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •