Results 1 to 5 of 5

Thread: Potential 580EXII Issue with 7D

  1. #1
    Senior Member
    Join Date
    Dec 2008
    Posts
    117

    Question Potential 580EXII Issue with 7D

    Hi All,

    Hope I'm not just suffering from bad memory. I've not shot with my flash in a while. I usually shoot in ETTL mode, but set my 7D to manual mode. I like to set my Speed/Aperture/ISO and let the flash adjust accordingly to get proper exposure. As an example, I have it set to f/4, 1/125s, 400 ISO with my 17-40mm. However, the exposure reading (through the viewfinder of my camera) is way to the left. I swear I could remember that being dead center before (i.e., proper exposure), meaning the flash will adjust to my settings for proper exposure.

    To experiment further, I tried moving the speed dial to see how it reacts. The exposure indicator finally moves close to center once I get to about 1/60s. But, I want to shoot faster! I swear I can remember shooting 1/250s before and it would adjust. Did I accidentally press a (series of) button that's causing this limitation.

    Btw, I did fire a few shots with my initial setting and they seem overexposed. Thanks in advance for your time and help.

  2. #2
    Senior Member
    Join Date
    Feb 2012
    Location
    Santa Clara, CA, USA
    Posts
    694
    Is the flash set to manual, or manual zoom?

  3. #3
    Senior Member Mark Elberson's Avatar
    Join Date
    Dec 2008
    Location
    Medford, NJ
    Posts
    1,037
    The flash will have zero affect on the camera's meter. Feel free to leave the shutter set where you want it. In ETTL the flash will set the exposure. (By set the exposure I mean that it will set the flash power to "properly" expose the scene) What you are seeing is how the picture would be exposed without the flash. Take two pictures, flash turned on and flash turned off. See what happens. Leave SS/AV/ISO wherever you want it.
    Last edited by Mark Elberson; 04-01-2012 at 03:51 PM.

  4. #4
    Senior Member
    Join Date
    Dec 2008
    Posts
    117
    @ahab1372: It's set to ETTL.

    @Mark: Okay, that is what I'm expecting. I just thought it was "illustrated" by the exposure showing dead center, i.e., to indicate it will compensate for my settings. I did a few more experiments after I started the thread and some of those shots looked to be properly exposed. It's starting to lean towards poor memory. Now, to go over 1/250s, I need to switch to high-speed sync, correct?

    Thanks for the responses, guys!

  5. #5
    Senior Member neuroanatomist's Avatar
    Join Date
    Dec 2008
    Location
    Boston, MA
    Posts
    3,716
    Correct. The camera meters independently of the flash, because the effect of flash on exposure isn't determined until the preflash (when you fire the shot). Obviously, you can dial in FEC separately from the ambient exposure you set on the camera.

    Over 1/250 s on the 7D means HSS, yes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •