Results 1 to 5 of 5

Thread: 5D III - shutter release w/o lens

  1. #1
    Senior Member
    Join Date
    Nov 2011
    Location
    Big Mouse Florida
    Posts
    1,037

    5D III - shutter release w/o lens

    I thought there was a to disable the camera looking for a lens. The 2x TC fits my russian beast but errors out.
    If you see me with a wrench, call 911

  2. #2
    Senior Member
    Join Date
    Dec 2008
    Location
    Planet Earth
    Posts
    2,900
    Tape on the contacts? Proceed at your own risk.

  3. #3
    Senior Member
    Join Date
    Dec 2008
    Location
    South West Ontario
    Posts
    466
    Use old manual lenses with non chipped adaptors on a regular basis in Manual mode both stills and Live View. Just tried my 1.4x TCs. The Canon refuses to play nice and throws Error 1. My Kenko continues to play well with others. It would seem that we have a winner!
    Picked up the Kenko some time ago as the different physical design allows it to be used on ALL of my lenses. You should get one, or two if you sell your Canon TC to cover the cost of buying the others.

  4. #4
    Senior Member
    Join Date
    Nov 2011
    Location
    Big Mouse Florida
    Posts
    1,037
    thought it might be the TC talking to the body.
    If you see me with a wrench, call 911

  5. #5
    Senior Member
    Join Date
    Dec 2008
    Location
    South West Ontario
    Posts
    466
    Thought it was odd that I had never run into that before. Then realized that I picked up the Kenko specifically for use with my old primes. The Canon TC has that part that sticks into the lens which interferes with the focus mechanism preventing focus beyond 20-30 feet depending on the lens.
    Glad that I have both and was able to narrow it down.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •